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Limitation of
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Prota shall not be held responsible for any losses caused by
documentation, software, or usage errors.
In addition to Prota License Agreement Terms, it is the responsibility of
the user
•

to check of results generated by documentation and software,

•

make sure that the users of the software and their supervisors
have adequate technical capabilities,

•

make sure that the software is used correctly per the reference
manual and documentation,

Intellectual
Property

ProtaStructure is a registered trademark of Prota Software Inc. All
intellectual property rights belong to Prota Software Inc.
Documentation, training, and reference manuals, and program
components can not be copied, distributed, and used in violation of the
license agreement.

Trademarks

ProtaStructure®, ProtaDetails®, ProtaSteel® ve ProtaBIM® are registered
trademarks of Prota Software Inc. Prota logo is a trademark of Prota
Software Inc.
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Introduction
Thank you for choosing ProtaStructure. This Quick Start Guide aims to get you up and running quickly.
You should be able to model, analyze and review the results for this simple model in around 1 hour.

User Interface
ProtaStructure 2022 welcomes you with a modern & efficient user interface designed from scratch for
ease of use. The various components of the ProtaStructure user interface are as shown below:
Quick Access

Tab Toolbar

File
Commands for the
selected Tab Toolbar
Refresh, Rotate, Zoom
3D View

Plan View

Search
Layers &
Display

Structure Tree

Views

Status bar – reveals important information, eg. required action to proceed

Command Entry

Units

Cursor coordinates

Ribbon User Interface
Toolbar Tab

Group

Command

Tooltip

The ribbon consists of several toolbars placed on various tabs. Each toolbar contains related
commands organized into logical & functional groups. Placing the mouse cursor over the command
will reveal the Tooltip explaining how to use the function.
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Generally,
you
create
the
model
from
the
left
to
right
ribbon
tab.
i.e., start with Building Setout > Modelling > Loading > Review > Analysis > Design > Drawings &
Report.

Views

Create as many views as you need, such as a plan, 3D physical Model, Analytical Model, and 3D rebars.
Views can be organized using smart window layout options.
Customize your work area by docking and floating views. The interface is compatible with multiple
monitors. If you want to make the most of your screenscape, just move one of the views to another
screen.

Structure Tree Search Option
Are you looking for a specific member or object? Type in the member label in the structure tree’s
search box and let ProtaStructure find it for you.

Search

Quick Access Toolbar
The Quick Access toolbar displays commonly used commands. Any command can be added to the
Quick Access toolbar by right-clicking on the command → Add to Quick Access Toolbar.
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Display Settings
Colors: Choose the background color and various active
modeling objects
Grid: Sets the spacing of the grid system to allow ease of
modeling as objects can snap to the intersection of the
grids
Object Snap: Choose the various snap options such as
Start/End/Corner, Perpendicular or Orthogonal Grid, etc.
Graphics Performance: Options that affect graphics
performance. Defaults will give optimal performance.

Active Window Settings & Visual Interrogation
Visual Interrogation: Color-code members to various criteria
such as design status, material types, beam with wall loads.
It is a vital visual tool to check and verify the inputs and
results of the model.
Scene Settings: Control the views’ graphics and switch
on/off the guiding Grids & Coordinate Axis, etc.
Visibility Filters: Filter to the specific storey, Axis, or member
type.
Column Plan Display: The column wall axial, moment &
shear forces to be displayed on the plan view.
Beam Plan Display: Allows brick/partition wall label, load
value & height to be color-coded and displayed in the plan
view. In addition, you can show the total user-defined load
(only after the analysis) & display beam elevation marks.
Slab Plan Display: The plan view shows the dead and live load values.
FE Contours: Shows the FE contours exported from the FE Analysis Post-Processing
Animation: Animate by spinning the model in 3D view
Each modeling window can have separate view settings.
For example, you might want to color the slab live loads on the plan view &, at the same time, color
design status in the 3D view.
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In the Scene Settings tab, the grid allows you to switch on/off the grey rectangular grids in the
background. Coordinate Axis will enable you to switch on/off the coordinate symbol.

Layer Toolbars (under Display Tab)
Layer and color settings

Switch on/off layers and modify the name, color, opacity, line type, line
weight, font type, and text height.

Axis Layer Group

switch on/off the axes layer

Column Layer Group

switch on/off the column layer

Wall Layer Group

switch on/off the wall layer

Partition Wall Layer

switch on/off the partition/brick wall layer

Beam Layer Group

switch on/off the beam layer

Slab Layer Group

switch on/off the slab layer

Ribbed Slab Layer Group

switch on/off the ribbed slab layer

Slab Load Layer Group

switch on/off the slab load layer

Slab Strip Layer Group

switch on/off the slab strip layer

Steel Bars Layer

switch on/off the slab reinforcement layer

Steel Member Layer

Switch on/off steel members such as truss, brace, purlins, girts, etc

Ghost Axis Layer Group

switch on/off the ghost axis layer

Plane Definition Layer

switch on/off the plane definition layer

Text Layer Group

switch on/off all the texts

Footing Layer Group

switch on/off the footing layer
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Start Page
When the ProtaStructure is launched, the “Start Page” will appear.

The Start Page contains the following functions:
❖
❖
❖
❖
❖
❖

Open existing project
Start a new project
Read Prota News and watch Prota Videos
Access Prota Resources such as Help Center, What’ New document & Quick Start Guide
Read important Notification and download new software Update
View Subscription status

You can always open the Start Page by going to the Help tab → Start Page.
Software update is checked automatically when there is internet connection.
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Starting a new project
➢ Click Open Project in the Start Page & the Open Project dialog will appear.
Here is the explanation of the functions in this dialog :

1

2
3

6
4

7
5

8

1. The Project Data Folder is the main folder where the project models are stored.
The project model consists of several files stored in a single folder called the Project folder. This
Project folder is created as a subfolder in the Project Data Folder. The project folder name will
always be created precisely the same as the project name.
2. A Data Folder called ProtaData2022 would be installed under My Documents by default.
3. If required, you can specify a different location by clicking Choose/Create Folder.
4. Clicking on Explore will open the current Project Data Folder in windows explorer.
5. You can open existing projects stored in this Data Folder by selecting the project list
After selecting the project, a preview of the project will be shown on the right-hand side
Double-clicking on the project name or clicking OK will open the project.
6. Click on the dropdown list below to expose the most recent accessed Data Folders.
7. Tick Most Recently Used Projects to show the recent projects opened quickly.
8. You can also read Project Last Saved Date to locate the saved project quickly.
Previous versions of ProtaStructure model can be opened directly in PS 2022:
➢ Firstly, you must choose the correct Data Folder by clicking Choose/Create Folder.
➢ Browse to the desired Data Folder (note data folder is the main folder, not the project
folder)
➢ You will then be able to see the project and open it.
➢ You will be prompted to save the model as another name.
➢ After converting, the project will open.
➢ Newer version projects can’t be opened in older versions of ProtaStructure (not backward
compatible).
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➢ Click New Project

and type the project name as shown using the ‘_’ character for spaces.

➢ Select Singapore (Eurocode) template

Templates are used to rapidly establish default model parameters such as design codes, material
properties, member design settings, etc. Alternatively, you can choose to duplicate settings from an
existing project by picking “Projects”.
➢ Click OK.
The main modeling area will now show a set of rectangular grids in the background.

By default, these girds spacing is 1m with a major grid colored darker every 5m. The defaults can be
changed via the Display Setting button
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Settings Center
The Setting Center can be accessed by clicking on the Settings icon in the Quick Access Toolbar or
from the Display tab (as shown below).

The Settings Center centralizes all the program’s default settings, including analysis, design and
detailing, and Units & format settings.

c

For example, when you initially start a project, it’s advisable to review the Automatic Save Interval in
the View & Save dialog. By default, “0” means it’s disabled.
➢ Change the Automatic Save Interval to 10 minutes to ensure the model is auto-saved.
➢ Untick Prompt for Automatic Saving to set the auto-save to run silently in the background.

Number of Backups to Save
The Number of Backups to Save refers to the automatic & silent additional backup created every full
hour. For example, the 1st backup file will be created at 9:00 am sharp, 2nd backup at 10:00 & 3rd
backup at 11:00. At 12:00 pm, the backup will overwrite the 1st backup, and the cycle continues.
The backup zip files can be found in a folder called “Backup” in the same Project Data Folder. The files
name will have the date and time stamp (example shown below)
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X

Project Template
The available templates are shown when you start a new project, and you must choose one. You can
reaccess these templates via the Building Setout tab.

1

3
D
My template B

2

C

A

Importing an existing Template → refer to step 1,2,3 above
You can change the template of a currently opened project by selecting a different template and
Importing it :
➢ Pick a Template (1) → Pick Select All (2) → Import (3)
All the settings of the imported template will apply to the current project.
Exporting a new Template → refer to step A, B, C, D above
You can save the settings of your current project as your template by Exporting it :
➢ Pick New Template (A) → Give it a name → OK → The new template will be created (B)
➢ Select the new template (B) → Select All (C) → Export (D)
The template will be successfully exported & can be re-used the next time you start a new project.
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Selection Methods
Selection is performed by placing the mouse cursor on a member or Axis in the modeling view.
Although there is no entity to select now, the information is essential as you work through the model.
➢ Left-click on the entity to select the entity. Selected entities are also highlighted in the Structure
Tree
➢ To select multiple entities, hold down the CTRL key while you pick them
➢ You can select entities directly from the Structure Tree
You can drag with the mouse to access further selection options:
➢ Drag from left to right to create a rectangular box. When you release the mouse button, all
entities wholly contained within the box will be selected
➢ Drag from right to left similarly, and all the entities that cross its boundaries will be selected
If you right-click the selected entities, you will see a pop-out context menu that allows you to edit and
perform other tasks related to that entity, such as Properties, Delete, etc.
Pressing ESC will deselect all entities.

Zoom & Pan Methods
The useful functions for zoom are just above the structure tree :
➢ Zoom Window

→ Zoom into the area defined by dragging a rectangle.

➢ Zoom Previous

→ Zoom to the previous view.

➢ Zoom Extents
→ zooms to the selected entities. If no entities are selected, it will
zoom to show all entities.
You will find it easiest to use the mouse wheel to:
➢ Zoom in
→ scroll your mouse wheel up
➢ Zoom out
→ scroll the mouse wheel down
➢ Pan (move)
→ hold down the middle mouse wheel and drag

Modeling Axes
The very first step to building a model is to define axes. Axes intersections then become the nodes at
which members are inserted. Hence, axes must be created correctly. There are three ways to model
axes:
1. Axis toolbar to build axes individually
2. External Reference Drawing to import all axes from the DXF drawing file.
3. Orthogonal Axis Generator to create a system of axes quickly
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Axis / Grid Tool
Modeling individual axes is simple using the program’s Dynamic Input System (DIS).
➢ Click on Grid

in the Modelling tab.

There are several insertion methods for the Axis:
Single Segment allows you to create a straight-line axis by clicking
on the start and endpoint of the Axis.
Multi-segment axis enables you to create a single axis with
multiple segments of any shape
Curve Axis can be created by specifying the radius
c
➢ Ensure Single Segment insertion is selected
➢ Put the mouse cursor on any of the grey grid intersections & the “Grid Intersection” snap is
shown

➢ Left-click (& release) to confirm the start point
A “rubberband” will appear as you move your mouse cursor to specify the endpoint

The length (L) and local angle will be displayed during the rubberband operation. In addition,
the relative distance ∆x & ∆y to the local UCS will also be shown.
➢ Press F2 to enable input of the length (L) of Axis via Dynamic Input System (DIS)
➢ Press TAB to cycle to the following input of angle.
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• The related parameter will be locked if a
value is entered in the textbox. You can unlock by
pressing ESC or pressing the lock icon at the right
of the text box.
• If a textbox is locked and F2 or ENTER is
pressed, DIS will be deactivated. However,
rubberband operation now continues with the
locked parameter for ease of use.

The left figure shows the length L is locked,
so you can freely rotate the Axis without
changing the length.

•

If both text boxes are locked, pressing ENTER will accept the operation, and the candidate
point will automatically be picked.

•

In either of the text boxes, you can use shortcut notation Length<Angle or DeltaX, DeltaY
(without the need to switch by TAB.)

Length<Angle

•

DeltaX,DeltaY

Holding down the CTRL key when the rubber band appears will lock the length & angle
increment as defined in Settings Center →ProtaStructure Environment → General → Angle
Step & Length Step input box.

➢ After specifying the length or angle, pressing ENTER or left-click will accept the endpoint
➢ Try inserting a multi-segment axis

by defining points continuously
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•

Use F2, TAB, ENTER to define destination points as mentioned earlier

•

Pressing ESC will cause a smart roll-back. If parameters are locked, the DIS is unlocked, then
the operation is canceled. If a pick-continuous command is active, ESC will unpick points.

➢ Right-click to end the operation and insert the axis

•

You are in axes creation mode when the axis property dialog is shown. Close it if you would
like to end the creation of an axis. The same sentiment applies to all member properties
dialog.

➢ Insert a curve axis by clicking on the curve axis icon
➢ Click on the 1st point and then the 2nd point

➢ Move the mouse cursor to the 3rd point that will specify the offset length of the curve.
➢ Left-click to confirm the 3rd point → Curve axis will be created

•

Alternatively, hit F2 to specify the offset length manually.
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External Reference Drawing
Note: This section is for information. A DXF drawing is required if you want to try out this feature.
ProtaStructure lets you load external DXF drawings and show them as ghost reference layers under
your model. The External Reference Drawing button can be found under the Quick Start menu.

c

This tool allows you to assign DXF drawings to different stories. Properties like unit, opacity, scale
factor, and offset can be set individually for each imported file. The whole state will be saved along
with the project data and restored; the next time the project gets opened.
Important! The referenced DXF files should be intact to restore the external drawing layer next time
the project gets loaded.

Add
Click Add to select and load a DXF file. The file will be converted into 2D drawing entities inside
ProtaStructure directly upon loading. However, it will not be visible until the Active box is checked.

Active
This checkbox controls the visibility status of the external drawing.

Unit
Please select the correct unit of the DXF file from the table’s unit column right after the file’s loading.
The drawing will be scaled immediately.

Storey No
The imported file will be assigned to the active story initially. You can use the ‘Story No’ column to set
it to any other level. Only one drawing can be attached to a specific storey.
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Use Colors
If this field is checked, colors defined in the file will be used; a grayscale drawing is displayed if
unchecked.

Opacity
This parameter controls the opacity of the colors. This field applies only if drawing colors are selected
to be used.

Scale Factor
This factor scales the whole drawing.

Move & Offset
Click the Move button and pick two points on the plan view to move the external drawing. Dynamic
Input functionality (hit F2) can be used here as well. The offset value between the two picked points
will be shown in the Offset column of the table.

Import
The selected reference drawing can be imported into the assigned story. In this case, the Import DXF
interface will be loaded with a pre-defined level and file unit values. The drawing can be imported to
the existing model in this mode.
A complete model can be developed from scratch in a controlled environment using the External
Reference Drawing interface and Import option.
For more guidance, e.g. 3D Physical Model & 3D Analytical Model import, kindly refer to Prota Help
Center : IFC and DXF Import Guideline
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Orthogonal Axis Generator
Let us now start the new model by creating the required model axes. We will define multiple axes in
one go using the Orthogonal Axis Generator.
➢ Select all existing axes that you have created → press Delete (or right-click → Delete)
➢ Go to the Modelling tab > Select Orthogonal Axis Generator
Refer to the bottom status bar; the displayed text tells you how to proceed.

➢ Pick the intersection of any two primary grids near the origin (as shown below)

Direction 1 axes are placed horizontally with alphabetic labels (incremented from bottom to
top). Direction 2 axes are aligned vertically with numeric labels (incremented from left to right).
➢ Accept all the default values in the inputs and click OK

Four horizontal and vertical axes with a 5 m spacing will be created.
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Columns Creation
➢ Pick RC Column icon
➢ Use the default size b1 & b2 and eccentricity e2 & e2 is as shown below

e2

e1

e1 & e2 is measure from the centroid of the column

Section Manager : Allows access other section types such as circular, “L”, “T”.
Column End Condition : Columns ends are fixed by default. You can apply hinges to top and/or
bottom by clicking successively on this icon.

➢ Insert columns by clicking on the intersection of axes
➢ Multiple columns can be inserted by dragging a box around the intersection of axes
Using the two methods, create ten columns at positions shown below.
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➢ Close the column properties. You finish member creation.
Always close member properties when you finish member creation, otherwise you will be
unable to proceed to other functions, such as member selection.
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Walls Creation
➢ Click on the Wall icon

& the wall properties will appear

➢ Use the default wall thickness b = 250 mm & e = 0 mm
The parameters are explained in the diagram below

e is measured from the centerline of the wall to its centroid. e = 0 means that the centerline of the
wall coincides with the centroid of the wall.
➢ Insert three walls by simply clicking on the shearwall’s start and end

Ext I & J : Slight extension to lengthen the wall should be kept small; less than its width as the
extension cannot support any members, such as beams.
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Beams Creation
➢

Click on the Beam icon

& the beam properties will appear.

e

e is measured from the beam’s centerline to its sectional area centroid. e = 0 means that the
beam’s centerline coincides with its area centroid.

e-z: +ve value raise the beam from the story level, -ve lowers the beam
End Releases: Beam ends are fixed by default. You can apply hinges to the left or right by
clicking successively on this icon.
➢ In the beam properties, use the defaults values b = 250 mm & h = 500 mm (as shown above)
➢ To create a beam, pick the start and the endpoints by clicking on the intersection of axes
Notice that you can continuously create the beams from the previous beam.

➢ Right-click to end the beam insertion after inserting the two beams as shown above
Multiple beams can also be inserted by dragging a box enclosing the area you want to insert
beams. Beams will automatically be created between columns and walls.

➢ Click and drag box enclosing the columns & walls shown above.
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Seven (7) new beams will be created.
➢ Insert the rest of the beams by any method as shown below

Check the folder Beams in the Structure Tree to ensure you have inserted a total of 18 beams.
We will now insert a curve beam in the lower right corner of the model.
➢ Click on the curve beam insertion icon

in the Beam Properties dialog

➢ Click on the intersection of axes A/3 and then the intersection of axes B/4 (i.e., start & end of the
beam)
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Define the apex distance by simply moving the mouse cursor, and the preview of the curve beam
in grey will show automatically.
➢ Press F2 to define the apex exactly as -1500 mm & press ENTER
A curve beam will be inserted (segments are automatically created). Check the Structure Tree that
you have modeled for a total of 19 beams.
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Beams Creation using dynamic snap points
Note: This section is optional and is not part of the final model, but you might want to try it anyway.
Secondary beams can easily be inserted using dynamic snap points (without creating axes).
➢ Click the Beam icon & place the cursor on the edge of the primary beam (avoid the Axis)

Place cursor on
edge of beam

Notice that snap points on 0.25L, 0.33L, 0.5L, 0.67L, 0.75L will be shown when the cursor is placed on
the beam.
➢ Click on 0.67L as the start point of the secondary beam.
➢ Place the cursor on the destination beam

Notice that 0.25L, 0.33L, 0.5L, 0.67L, 0.75L & perpendicular point will appear
➢ Select the desired point as the endpoint of the secondary beam & a new beam will be created
Pressing F2 while the cursor is at any of the snap points will allow input of the exact distance from the
start of the beam.
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Pressing the CTRL key while the cursor is placed on the edge line of the primary beam will expose a
distance increment of 100 mm. Left-click to select the desired distance (while still holding down the
CTRL key).

The step increment can be set Building Setout → Settings Center → ProtaStructure Environment →
Length Step.

Handy Tip to adjust the position of columns and beams
You can change the position (eccentricity) of the column and beam by simply selecting it & then
pressing keyboard arrow keys to move in the direction you want.
➢ Select column GC1
➢ Press right arrow key → to move the
column to the right

The step by which the member is moved can be set in Building Setout → Settings Center →
ProtaStructure Environment → Member Section Eccentricity Step (by default 25mm).
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Load Combinations
Before creating slabs, we need to define the load cases & combinations.
➢ Go to the Loading tab, click Load Cases and Combinations

You can add new load cases manually and then load combinations. However, it’s easiest to use the
Loading Generator to set up load cases and combinations automatically.
➢ Pick Loading Generator & use the options as shown below and click OK

You can choose which combination is used for concrete & steel design separately.
If “Use Cracked Sections” is checked, Section Stiffness Factors will be applied for that load case.
As shown below, all the load cases and combinations will automatically be generated.
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➢ Pick OK to save & close the Load Combination Editor.

Slab Creation
➢ Click on the Slab icon

and the slab properties dialog will appear
➢

Click on the Type box
All the possible Slab Types will appear in pop up menu.
The slab type 1 to 12 relates the slab edge continuity and is
used in the design of the slab reinforced based on the
coefficient / yield-line method.
Type 1 to 12 does not affect the slab load calculation on the
supporting beams, only the design of slab using coefficient
method.

One-way slab. The slab load will only to be
transferred to the 2 supporting beams in the direction
of the span.
The direction of one-way span must be specified in the
Design Angle input box :
Label Position icons activate the slab label and control the slab label’s position.
Insertion method: By default, “Beam Region” is selected. This means the slab will be inserted within
the region bounded by the beams.
➢ Select Slab Type as 1
For ease in creating this model, we will initially leave Slab Type as 1 for all slabs. Once they have
been created & when we are ready to design the slab, there is a function to automatically set the
correct type for each slab (covered later).
➢ Enter the slab thickness h = 200 mm and concrete cover = 30 mm
➢ In the Loads tab, enter Service Dead Load = 1.2 kN/m2 and Imposed Load = 3 kN/m2

Page - 32

Different types of service dead load can be defined via Building Setout → Slab Additional Loads library.
➢ Position the cursor in the region bounded by beams @GL 3, 4, C, D, and left-click to create a slab.
The first slab will be inserted.
The yield line shows the tributary area load this is
automatically calculated onto the supporting beams.
By default, slab load calculation is done
automatically onto supporting beam using yield-line
method.
➢ Create seven more slabs to give the layout shown below
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Inserting Cantilever Slabs (Type 12)
Note: This section is optional and is not part of the final model.
Cantilever slabs can be inserted by setting Type = 12 in the slab property. They are inserted by three
clicks - clockwise or counter-clockwise direction does not matter. Cantilever slabs can span more than
one beam or wall.
➢ Zoom to the top-right corner of the model
➢ Click on Slab icon & choose Type 12 & enter h = 150mm
➢ Go to Cantilever tab → Enter L-Cant = 1000 mm (cantilever length)
2

3

1
➢ Pick the first intersection of the Axis to define the start of the cantilever
➢ Pick a second point to define the end of the cantilever
➢ Move the cursor to the side where it is to be inserted → a grey preview will be shown
➢ Pick the third point to confirm & insert the cantilever
To insert a cantilever slab that does not span the entire length of the beam, we must enter values of d
& b-slab in the cantilever slab properties :
➢ In Slab Properties, enter d = 1000 mm & b-Slab = 2000 mm

d

b

➢ Pick the first intersection of the Axis to define the start of the cantilever
➢ Pick a second point to determine the end of the cantilever
➢ Move the cursor to the side where it is to be inserted → a grey preview will be shown
➢ Pick the third point to confirm & insert the cantilever
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Polyline Slab/Column Edge
Note: This section is optional and is not part of the final model.
The slab edge line can be used to create irregular slab shapes
➢ Click Polyline Slab/Column Edge

under Modelling

➢ Click continuously to define the edge of the cantilever slab.

The method to draw the edge lines is similar to a multi-segment axis.
➢ At the last point, right-click & pick Finish to end the insertion. The slab edge lines will be drawn

➢ Click on the Slab icon → Ensure Type = 1 is selected
➢ In the insertion, ensure that Beam Region is selected.
➢ Click anywhere within the slab edge line, and a new slab will be created.

For regular cantilever slab, it is recommended to use Type 12 in slab properties (instead of slab
edge lines).
The slab/column edge line also includes Circle, Arc & Rectangle and the ability to convert to a
column or slab hole or slab drop. After drawing a closed shape line → Select it → Right-clck →
Convert to Column or Slab Hole/drop.
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Views Creation
The graphical editor supports multiple windows; this allows you to create different views in separate
windows. The Views tab commands can be used to create new views and to arrange the views.

➢ Go to Views tab → Click 3D Physical Model
This command will create a 3D physical model view.
➢ Click Tile Vertically → This will tile the plan and 3D view side by side

You can select & modify existing members or insert new members in the 3D view the same way as the
plan view.
Note: Alternatively, you can right-click on Views in the Structure Tree or header field of the existing
view tabs to create new views.

➢ Select the curve beam in the 3D view. Notice the same member will be selected in the plan view.
➢ Right-click (to access the context menu) → Properties
➢ Change the depth of the beam h-bot to 600 mm
➢ Click Update and Close the beam properties
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Inserting Storeys & Defining Building Parameters
The final model will be a four-story building. We will now insert the other floors.
➢ Go to Building Setout → Storeys Operations dropdown → Insert story.
➢ Alternatively, right-click on Storey and pick Insert Storey

➢ Input Total No. of Storeys = 4 → OK

➢ When prompted to confirm → Pick Yes
This automatically inserts stories 2, 3 & 4. We will now edit the information of the stories.
➢ Pick Edit Storey from the same Storey dropdown menu to enter the Edit Storey dialog
➢ Hold CTRL key and multiple select Storey 1, 2 & 3. Then click “Define selected stories as similar.”

Storeys 1, 2 & 3 will now be identical. Since we have already inserted members in story 1, these
members will be automatically copied to stories 2 and 3. In addition, changes to a particular similar
level will be applied automatically to all similar stories.
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For storeys to be identical, they must also have the same storey height. In an actual project, ST01 is
the ground floor & will have a shorter storey height & hence should not be made similar.
➢ Change the member label under the Labels column as shown above, e.g., “G” for ST01 and “R” for
ST04.
ST01 members will be labeled GB1, GC1, etc.
➢ Click OK to exit and notice that the 3D view shows storey 1, 2 & 3 with identical members.
Storey 4 (Roof) has no members, so that we will generate (copy) members to this storey.
➢ Pick Generate Storey from the same Storey dropdown

➢ Under Source Storey, pick Storey 1 & then select Storey 4 as Target Storey
➢ Click OK, and members will be copied from the ground floor to the roof
➢ Click Close and check that members are indeed created in storey 4
➢ Switch to show storey 4 in the plan view by double-clicking on storey 4 in the structure tree
➢ Create a new slab with the same properties over the lift core since this is the roof level
➢ Press ESC to deselect all previously selected members
➢ Right-click anywhere on the plan view to expose the context menu
➢ Select Member Tables → Slab Table
The slab table allows you to view & change the parameters of the slabs in a group

➢ Click on the header q (live load), and the entire columns will be highlighted
➢ Click the Column-wise Edit icon at the top
➢ Enter 0.75 kN/m2 → press ENTER (all the slabs live load values will be changed)
➢ Close the Slab Table
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Wall Loads Library
You can set up pre-defined wall loads and then apply them using a dropdown list when adding the wall
loads.
➢ Go to Building Setout → Partition Wall Loads

Defaults wall types are automatically set up, but you can add any new user-defined wall type.
➢ Choose Cancel to exit
We will now insert brick wall loading on the beams in ST01.
➢ Make the plan view active by clicking on it
➢ Double click on ST01 in the structure tree to make it active
➢ Select the bottom-left most perimeter beam along with Grid A / 1-2
➢ Click Load Editor

in the Beam tab that appears.
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Member Load Editor
The load editor of the beam will appear once the load cases and combinations are generated.

6

1
2

4

5

3
6

1. Load Types
• Click to choose the load type to insert, e.g., point load, full uniform load.
• Self-weight & decomposed slab loads are auto-calculated & cannot be edited.
2. Load Case & Loads Folder & Load Properties
• Choose the load case to insert the loads. Existing loads will be listed for the selected load cases.
• Click on the load name to select it > Right-click will expose menu options to Edit, Cut, Copy or
Remove the load.
3. Load Properties
• Enter Label, Direction & Magnitude values for the load to be created.
• Select it in the Loads Folder or Loads diagram > Revise values > Click Update to update an
existing load.
4. Loads Diagram
• It displays the graphical representation of the loads, including self-weight & slab loads
calculated on beams.
• Existing loads can be selected by left-clicking on the diagram > Right-clicking will expose menu
options to Edit, Cut, Copy or Remove the load.
• Click on the beam diagram to insert a load after choosing the Load Type & input values in the
Load Properties.
• The load coordinate system is shown with X, Y, Z arrows. The beam & loads diagram can be
rotated by right-clicking & drag.
5. Load Type filter
• Click the Load type icon to toggle on and off the associated diagrams.
6. View Options & Shortcuts
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• These settings control the rendering of the member, loads graphics, text height, scaling & frame
labels.
• Show Loads as merged
: Loads under the same load case will be combined in a single
diagram. This option must be switched off to edit or remove the load.
• Show Infill Wall as link Load
: If “on” infill wall will be shown as line usual line loads. The
infill wall will be rendered with actual height and width if the setting is turned off.
Let us insert a 100 mm preset brick wall load on this beam :

➢ Pick Wall Load

under Load Types ribbon.

Notice only the wall load type layer will be active, and all other load types will be switched off
➢ Ensure G load case is selected in the Loads Folder at the left.
➢ In the Load Properties, Wall Load Library, pick 100 Brick Wall - Singapore. Note wall height is
preset to 3000mm = storey height.
➢ Place the mouse cursor on the beam & left click to create the load.
The load will be created and added in the diagram & loads folder.
➢ Press the ESC key to finish the wall load insertion process. Click OK to save & exit.
Partial wall can be entered by checking selecting Measurement Type = Distance or Percent :
➢ Enter Start & End Offset
➢ Alternatively, check Define Wall Length Manually
Wall Opening, e.g. of windows & doors can be inserted by clicking “Edit Openings”.
The brick wall load will be rendered in 2D and 3D views. Notice wall load is also copied to a similar
storey as expected.
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Storey Load Editor
Loads can also be entered for the entire storey, instead of a single member :
➢ Ensure ST01 is active & no members are selected (press ESC key)
➢ Go to Loading tab > Pick Load Editor Storey: 1

The storey load editor is similar to the member’s load editor, except that all the members & loads on
the active storey are shown. The differences are described below.

2

3

1

1. Load Types
• Surface Loads are loads are area loads that can be applied to slabs and walls
• Self-weight is auto-calculated & cannot be edited.
2. Load Case & Loads Folder
• Choose the load case to insert the loads. Existing loads will be listed for the selected load case.
• Loads folder resembles the Structure Tree, which organizes loads under member type
• Show only Loaded Members: If checked, will omit any members without any loads from listed.
• Expand the folder > Click on the load name to select it > Right-click will expose menu options to
Edit, Cut, Copy or Remove the load.
3. Member Filter
• Toggle visibility of member type in the diagram. For example, if the Beam layer is off, then all
beams & loads applied to beams will be hidden.
We will now copy the brick wall load to all the perimeter beams.
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In View Options : Show Loads as merged is by default deactivated, so that the wall loads are shown
separately. Show Infill Wall load as Line Load is by default activated, so wall load is shown as line
load, instead of drawn to actual wall height.
➢ Choose G load case in Loads Folder.
➢ In Member Filter, toggle off the Slab layer, so the slab and slab area loads are turned off.
➢ In Load Type Filter, toggle off uniform load

& Slab Loads

, to isolate the wall loads

➢ Select partition wall load in the diagram > Right-click > Copy
➢ Multiple select all the perimeter beams by holding down the CTRL while selecting the beams.
➢ Right-click > Paste > Check the same wall load is pasted correctly.
➢ Go to Load Types tab > Click OK

➢ Examine the 2D & 3D views to ensure all wall loads are inserted correctly.
Alternatively, wall loads can also be copied in the plan view by the following steps :
➢ Select beam with wall load inserted
➢ Right-click > Copy Loads > Select the brick wall load > OK
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The load case & load type panes act as filters for selecting the load name on the right pane.
➢ Multiple select the perimeter beams where loads are to be pasted (holding CTRL key)
➢ Right-click > Paste Loads
Similar steps can be used to delete loads by selecting beams > Right-click > Delete Loads.

Defining Slab Load via Load Editor
You will learn how to insert slab line load.
➢ Double Click on the Storey 4 in the structure tree (to make Storey 4 active).
➢ Select the bottom left-most slab, 4S1 > Click Load Editor
A slab load Editor will appear. It is similar to beam load editor but with additional surface loads type.

End Pt

Start Pt
Local Axis + Origin

➢ Go to Loading Types tab > Click Uniform load
Note all other load type layers will automatically switch off for clarity.
➢ In the 3D orientation cube, click on Top

> view direction will change to top

➢ Ensure G load case is selected
➢ For Magnitude (Start) & (End) > Enter 5 kN/m
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➢ Pick the Start point on the load > Pick the endpoint (approximately vertical)
The line load will be created with a default magnitude. To edit the load :

➢ Press the ESC key to end the line load creation mode.
➢ In the Load Filter, switch off Area Load

> Area loads will be hidden for clarity

➢ Select the line load name in the load folder or the 3D diagram (rotate the view to suit).
➢ For Measurement Type > Choose Distance
The Insertion inputs will show the location & magnitude of the load in table. The X & Y inputs are with
reference to the local axis origin
➢ Change the values as shown above > Click Update > OK to exit the dialog
The line load will also be shown in the model plan & 3D view.

To edit the slab load, you can select the load in plan or 3D view, Right-click > Properties.
To delete the slab loads, you can select the load, press DELETE key or Right-click > Delete.
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Defining Slab Load (via plan view)
Slab loads can also be defined on the plan view of modeling.
➢ Go to Loading tab > Click the Point, Line, and Area Loads icon
The slab load properties will appear as shown below.
➢ Select the Line Load icon
➢ Define Angle = 90 degree, length of line load, b1 = 2000 mm and Load
values at start and end, w1 = w2 = 5 kN/m.
➢ Pick the intersection of axes A/1 (reference point)
➢ Press F2 to define the relative coordinates. Enter “2500,2500” which
means X = 2500 mm & Y = 2500 mm as shown elow

Alternatively, you click on 2 points to define the start & end of the line load (without specifying
Angle & b1)
You can insert a partition wall load by clicking on the dropdown menu under “Wall” and select from
the preset wall types library
➢ Press ENTER & the slab line load will be created.

➢ Delete this line load by selecting it > press the DELETE key
You may use the external reference drawing to display the architectural drawing at the back of
your model as a guide for creation of members or slab load.
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Slab Opening Creation
You will learn how to define the coordinates and size of the Slab Opening.
➢ In ST04, zoom to slab between GL A-B/2-3.
➢ Click the Slab Opening/Drop icon
in the Modelling tab, and the slab opening properties
dialog box will appear as the figure below.
➢ Define the slab opening horizontal length, b1 = 1000 mm & vertical
width, b2 = 500 mm.
➢ Pick the intersection of axes A/2 as the reference point of insertion
➢ Press F2 to define the relative coordinates
➢ Enter 1000,1000 which means X = 1000 mm & Y=1000 mm in the
textbox as shown below

➢ Press ENTER & the slab opening will be created

➢ Click Close in the Slab Opening Properties dialog box
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Member Re-labelling for Entire Building
The members are labeled automatically in the sequence they are created.
➢

To re-label the members systematically, go to Review Tab > Re-label Members

➢ Select all Members type
➢ Change all Sort Reference to Let-Bot --> Right-Top.
This means that the left-bottommost member will start with number 1.
➢ Tick Retain Compatible Labels Between Storeys.
This setting forces the members at the same position to have the same label across all storeys
(e.g., 1C1, 2C1, 3C1 will be at the exact location).
➢ Click OK.
The members will now be re-labeled systematically with label 1, starting with the left bottommost
member.
It is a common practice to have vertical member (column & wall) retain the same labels between
storeys, whereas this may not be preferred for horizontal member (beam & slab). To achieve this,
you can run the re-labelling twice for different member types with Retain Compatible Labels
checked & then unchecked.
The model is now completed, and we are ready to run the analysis.
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Building Analysis
➢ Go to the Analysis tab →click Building Analysis

→ Pre-Analysis tab

The Pre-Analysis setting is where the main assumptions of the analysis can be defined :
•
•
•

•

Settings Center: Access settings center to review & modify analysis parameters such as the
design code and notional horizontal load
Load Combination: generate, add or modify any load case or load combination sets.
Wind and Storey Load: automatically generate wind loads, review & input any lateral load.
Automatically generated lateral loads such as the notional horizontal loads will only be
calculated and shown after the analysis.
Edit Materials: review, add, or change the concrete and steel material of the building.

Page - 49

Materials
We will now define the materials for this project via Building analysis> Pre-Analysis dialog.
➢ Pick Edit Materials

The materials and reinforcement steel grades are shown for all member types. Default Material is
used for super-structure floors. A separate Foundation Floor category is automatically created for
foundation members only.
If a different material is required for a particular storey, a separate material set can be added by
picking the

icon. Steel reinforcement grades and diameters are also defined here.

➢ Pick Column Concrete Grade → select C30/37 → Apply to all members in this storey → OK

➢ Pick Steel Grade and ensure that Grade 500 (Type 2) is selected and applied to all member types
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➢ Click “Edit…” next to Rebar Diameter & the rebar table will appear

➢ In left hand Filter pane, tick Column, Wall, Beam & Slab to hide diameters of other members
➢ Tick the diameters of bars to be used in the design of those members as shown above. Generic is
for all other elements, at least 1 rebar must be ticked.
➢ Click OK to close Rebar Table > Click OK to close Rebar dialog > OK to close Materials dialog.

Load Combinations
We have already generated the cases and load combinations previously, as shown below.
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➢ Review & click OK to close the dialog.

Wind and Storey Loads
Allow user to review & input lateral loads such as notional horizontal & wind loads. We will skip this
for now.
Wind load cases and combinations must be generated first. For more guidance, kindly refer to
Prota Help Center : Wind and Storey Loads

Building Analysis Model Options
➢ Go to the Model Options → Model → Material & Section Effective Stiffness Factors and review the
stiffness factors as shown below.

The stiffnesses table will only be applied for load cases with Used Cracked Sections checked in the
respective Load Case Editor, except for seismic load cases where cracked sections are always
assumed.
All factors can be modified, except those that are greyed out, which must be auto-calculated.
Building analysis must be repeated each time the effective stiffness factors are changed.
To prevent large torsional forces in primary beams due to secondary beams, the global Torsional
Stiffness Factor is by default set to 0.10 (10%) in the Stiffnesses settings.
Stiffnesses of individual members can be changed by selecting a member → Right-click → Edit
Section/Material → Properties tab.
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Running Analysis
➢ Go to the Analysis tab
Before running the analysis, it’s always recommended to check the model’s validity.
➢ Click Building Model Check & pick All Storeys & click Start
The building model check will pick up the most obvious
modelling errors as indicated.
The warnings / errors are mostly self-explanatory. The
exact member(s) affected will be stated.
You should review any warnings / errors and correct the
model before proceeding to perform analysis.
Click “Load Log to Editor” to open the list of
warnings/errors in a separate screen in Notepad for
ease of reference.

➢ Click Close to exit the check
The building analysis can now be performed.
➢ Click Building Analysis
Eigenvalues analysis can be done to obtain the natural
frequencies and mode shapes of the structure.
The Batch Design Options dialog will appear. It allows you
to perform the design of column/wall and beams
automatically after the analysis. We suggest that this
should only be done if you are confident that the analysis
result is correct.
➢ Check Column/Wall Reinforcement Design
➢ Check Beam Reinforcement Design
➢ Pick Building Analysis to analyze & design the model
The analysis will also check for instability and large
deformations and there will warning messages if any are
found.
The Analysis Summary Report will appear at the end of the analysis, summarizing the essential results.
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Axial Load Comparison Report
An important check on the validity of the analysis is the Axial Load Comparison Report. This report
sums all the dead and live load applied at each storey and displays the axial forces in the columns and
shear walls. These values need to agree within a tolerance limit of 5%. If they do not, the reason for
the discrepancy should be investigated.
➢ Select Axial Load Comparison Report (in the Analysis tab)

Table 1: TOTAL LOADS (Based on Slab) is the sum of dead and live loads of all members with the slab
load not yet decomposed or calculated on the beam. You can take this as the input weight of the
structure.
Table 2: TOTAL LOADS (Decomposition to Beams) considers the decomposition of the slab load onto
the beams based on either yield-line or FE Decomposition. The beam load now includes the slab loads
(and hence zero values are shown under the slab column).
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Table 3: BUILDING ANALYSIS COLUMNS AND WALL AXIAL LOADS sums up the actual column and wall
axial loads after building analysis.
Firstly, check Table 1. Total values are similar to Table 2. This ensures that beams accurately capture
all slab loads, i.e., no lost slab loads.
Then verify Table 2 total values are similar to Table 3. This ensures that all the super-structure weight
is entirely captured by the columns and walls down to the foundation.

Analytical Model
The Analytical Model enables you to review the results of the analysis graphically. It is essential to
check & verify the analytical model to ensure the model the correctly set up & results are reasonable.
➢ Go to the Post-Analysis tab of the Building Analysis dialog
➢ Click Display Analytical Model
A new Analytical Model tab set will appear with the Analytical Model view.
Analytical Model
ribbon tabs

X to close view
Filter functions

Load Cases

Load
Combinations

The analytical wireframe is shown in blue. Load cases and combinations can be selected on the rightside pane.
If too much information is displayed, the screen can appear cluttered. However, you can create a
more meaningful display view by using the various filter buttons and the view settings.
➢ In the General tab, click on the Filters command (if it’s not activated)
The filter options will appear on the left-hand side of the view. There are options to filter the
display by Storeys, Axes, and Member Type.
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The Find command allows you to find a particular Node, Frame, or Shell number.
Connectivity Issues lists all the frames with unsupported nodes and highlights them when
selected.
➢ Click the Members tab
This is where you can show node labels, rigid diaphragms, element labels, and beam loads.

➢ Click Frame Loads & Frame Load Labels icons to show loads calculated or decomposed on the
beams (& then turn it off).
This may include all the slab loads, brick wall loads, beam self-weight & other manual input loads.
➢ Click Diaphragms → Select All will show the rigid diaphragm formed by the slabs (& then turn it
off).
The grey lines join nodes constrained by the diaphragm to the center of the diaphragm mass.
➢ Click on the Results tab

➢ Click Displacement → The red lines show the structure’s displacement (deflection).
By default, Auto Scale is activated. You can deactivate this and then type in your Scale.
Displacement Unit can be changed in the Settings Center > Units and Format
➢ Click on the various directional displacement values by selecting x, y, z & R (Resultant). Rx, Ry, Rz is
the rotation of joints in radians.
The Maximum and Minimum displacement is shown at the bottom of the screen.
➢ Click on this legend → an arrow will appear to pinpoint the node of maximum displacement.
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Deflections shown
in red lines

Click on this legend to
locate max displacement

➢ Click Animation to visualize the deformation of the structure.
➢ Switch off the Displacements display and click on the Diagrams button.
➢ Click on the Axial force N icon to display the Axial Force diagram (for G Load Case).

Diagrams Legend
N - Axial forces
V2 – Major shear force of beams
and walls. Shear of column along
dir 1
V3 – Minor shear force of beams
and walls. Shear of column along dir
2
M2 – Minor moment of beams and
walls. Moment of column along dir
1
M3 – Major moment of beams and
walls. Moment of column along dir
2
T - Torsion
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➢ Experiment with the various effects of the diagrams.
You can change the diagram scale by de-activating Auto Scale & typing the desired Scale.
You on/off the diagrams on Column, Shear walls, Beams & Rigid link by clicking on the respective
icons.
➢ Click Properties icon
& select a frame member will show the detailed member properties,
including material, section properties & summary of analysis forces at both members ends.

Contours tab will show contour results for shell elements which will only be visible if finite element
shell walls is assumed, or floor slabs are selected to be meshed in Building Analysis.
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➢ Go to the Solid Model tab.
This allows the various effects such as Axial Load & effects to be color-coded on the physical
model.

➢ Close the Analytical Model view by clicking on the “x” sign next to the view name.
➢ Alternatively, you can click to switch to plan view
interface.

and exit the Analytical Model

You must interrogate the Analytical Model and check its validity as that is the actual analytical model
from which the design forces will be based.
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Column & Wall Design
➢ Navigate to the Column Section Design under the Design tab
Since we have selected to run column reinforcement design as part of Building Analysis, all the
columns and walls are already designed as indicated by a green tick.

If they are not designed, you can choose Column Design (Batch Mode) → Reselect All Bars to design all
columns at one go.
➢ Go to the Reports tab → Choose Design Report
A tick in the Print column marks the columns included in the report. Columns can be added or
removed from the report by checking or unchecking the Print checkbox. Furthermore, icons Mark All
Columns and Remove Print Marks can be applied to all columns.

➢ Check “Include Column/Wall Sections in the Report” to draw the column section detail.
You can also give the report a title.
➢ Pick OK to generate the report
All reports can be exported in PDF, MS Word, image, or webpage (HTML) format.
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➢ Exit & this report will automatically be saved & made available for compilation in Report Manager
The Interactive Column Design allows you to examine & alter individual column designs in more detail.
➢ Double click on GC1 in the list of columns in the Column Design screen.
Section
Dimension
shows
the
parameters of the column such as size,
clear height & concrete cover
Steel Bars shows the number and
layout of the rebar. These can be
changed.
Load Combination table list down all
the load combination. The most critical
(governing) is highlighted in red.
Required & Supplied As are calculated
from the critical load combination.
Slenderness tab shows the bracing
assumption,
calculated
effective
lengths & additional moments.
If there are changes in the assumption of this column, you can click the Interactive Design button to
re-perform the reinforcement design.
You can change the dimensions (b1,b2) above & click Update. This is handy if a column fails due to
insufficient size & you want to try out if a bigger size works. However, due to the change in column
size, the weight & stiffness of the model will change. Hence, you should re-run the analysis and recheck the column design to ensure it is sufficient finally.
➢ Click Column Analysis to inspect the Interaction Diagrams (capacity curves).
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The Interaction Diagrams (N-M) show the possible combination of axial force and moment that cause
failure to a given column dimension and rebars. This “capacity curve” indicates the maximum axial
capacity of a reinforced column is dependent on the co-incident or applied moment (vice versa). The
axial capacity of the column decreases as the applied moment increases until the ‘Balance point’, the
max moment capacity. After this point, moment capacity decreases with decreasing applied axial load.

Design Combinations

Balance Point

➢ Select Interaction Diagram (N-M)
For rectangular columns, there will be 2
capacity curves in direction 1 and direction 2
respectively.
The governing design will be the smaller
curve; for this column in will be along dir-2,
the shorter dimension & hence weaker
capacity.
➢ Select Dir-2 (N-M11)
To verify that this column passes with the
rebar selected, all the design combination
points must be within the curve, especially if
you have manually changed the rebars in
Rebar Table.

The Interaction Diagrams (M11-M22) plots the component M1 & M2 moment capacity of the column
at a given applied axial load.
➢ Close the Interaction Diagram and go to the Slenderness tab
The Slenderness tab shows the bracing conditions of the column/wall, effective length factors &
additional moment (M-add) due to slenderness.
For this column, it is braced in both directions, the
calculated effective lengths β are less than 1 &
hence M-add is zero or minimal.
You can change the bracing condition manually.
➢ Untick both Dir-1-Braced & Dir-2 Braced
➢ Click Interactive Design to refresh the design
➢ Go back to Slenderness tab to review
Notice that the unbraced condition of the column
now results in effective lengths > 1. As a result the
additional slenderness moment, M-add is
calculated and auto-added to the base design
moment to become the final design moment.
If you want to manually save either the Bracing or
β factors, ensure to tick “Edited”. This means the
design module will not auto-calculate these values
anymore.
➢ Click Diagrams to view the shear force, bending moment, or deflection diagrams.
➢ Click Elevation Drawings to view the reinforcement of the column in elevation.
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Manually Specifying Column Design Forces (for info)
The column design forces are automatically linked and updated to the latest analysis run. You can
over-write the column design forces manually.
To manually enter column design forces :

5

1. Select the first row of column design forces
To select more rows, hold down CTRL key

2. Pick Select Marked Combination as User Defined
3. Click on figures under “N” axial load & enter

2

figures for top and bottom, e.g. 1000,1000

1

4. Pick Select / Unselect All to select all rows
5. Click Interactive Design to refresh the design
6. Untick User Defined Loads to auto-link back to

3

analysis forces.

4

Manually Change Column Reinforcement (for info)
The column design module will automatically design the column to pass status. However, there are
situations where you might want to specify the reinforcement manually & check if the column passes.
To manually fix the layout & number of rebars & let column design auto-select rebar size :

1. Input “2” for 1-int under Qty column

4

2
3

Notice diagram now shows 2 nos. internal
horizontal bars on both sides

1

2. Pick Parameters
3. Pick Fixed Bar Layout Method → OK
This option ensures that the number of bars
will not change during re-design

4. Click Interactive Design to re-design
The column will be re-designed to 8 number
of bars as specified. If this reinforcement is
insufficient, the program will auto-increase
the bar size, say from H13 to H16.
You can also manually change both the number of bars and rebar sizes (i.e., both Qty & Diameter). Do
not click on Interactive Design, which will change the rebar sizes. You must then manually check the
following to ensure the column passes :
➢ Check As Supplied is more than As required and Min Steel %

➢ Click Column Analysis → Check all design points are within the Interaction Diagrams N-M11 & NM22

➢ Click Cancel to exit the Interactive Column Design dialog and Close the window.
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Beam Design
➢ Go to Design tab → pick Storey Beams
Since we have selected beam reinforcement design as part of Building Analysis, all the beams are
already designed as indicated by green ticks.

If they are not designed, you can choose Beam Design (Batch Mode) to design all beams at one go.
A tick in the Print column marks the beams included in the report. Beams can be added or removed
from the report by checking or unchecking the Print checkbox.
➢ Choose Remove Print Marks to exclude all beams in the report
➢ Check/tick the checkbox under Print for the first-row beam axis A only

➢ Choose Design Report

The Beam Design Report is in rich text format.
Choose the preferred Report Options to
include the various force diagrams.

➢ Pick OK to generate the report
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➢ Exit & this report will automatically be saved & made available for compilation in Report Manager
The Interactive Beam Design allows you to examine individual beam design in more detail
➢ Double click on any of the beam axis in the list of beams in the Beam Design dialog
Reinforcement Data window shows the
details of the beam design.
Required As is shown in blue as is based on
design envelope of all load combination.
Extra As shows the additional or surplus
area of steel based on selected steel.
s-Bar-CL (Top)/(Bot) shows the spacing of
the rebars at the outmost layer.
Deflection Check shows the actual vs
allowable span/effective depth. The
modification factor is automatically applied.
Rebars designed are shown in the various
rows including shear links. These can be
manually changed if desired.
Any figures in red indicate a failure to meet the design criteria and should be investigated.
➢ Click on the Diagrams button to see the loading and design forces.
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Display Detailed
Values

Loads, Diagrams
& Deflections

Loads Cases &
Combinations

Visualization
Tools

Loads, Diagrams & Deflections
❖ Display Detailed Values :

•

Checked: A tracing window will appear showing the exact values of the diagrams, e.g., shear &
moment, when the mouse cursor is placed at a particular location on the member.
❖ Optimize Stations :
•

Unchecked: The diagrams are displayed using the default maximum number of stations.

• Checked: The number of stations will be reduced & optimized to maintain similar accuracy.
❖ Diagrams :
•

L1/ L2 / L3: Check to show slab loads decomposed & user-defined loads on beams

•

N = Axial force ; T = Torsion

•

V2 = major shear ; M33 = major moment ; δ2 = major deflection

• V3 = minor shear; M22 = minor moment ; δ3 = minor deflection
❖ Deflection Display Types :
Deflections are calculated along the member span for each load case and combination. Deflections
can be displayed in three different ways:
•
•
•

Absolute: The absolute rotation and deflection values display the deflected shape.
Normalized: The absolute shape is normalized to the value calculated at the first point.
Relative: The deflected shape is normalized to both start and endpoints. This is particularly
useful in determining the deflection relative to both ends in serviceability checks.

Visualization Tools & Report
❖ Horizontal Scale
❖ Default Display Scale

→ Increase or decrease horizontal Scale of diagrams
→ click to reset to the default scale
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❖ Increase / decrease font size
❖ Default Font Size
❖ Report

→ Click to rest to default font size

→ Generate a report in tabular format with/without diagrams.

➢ Exit the diagrams & Close the beam design dialog

The same beam diagrams can be assessed by :
➢ Select a beam on plan view → Right-click → Analysis Results Diagram
The same diagrams are used for columns & walls :
➢ Select a column or wall on plan view → Right-click → Analysis Results Diagram
➢ Alternatively, access the Interactive Column Design → pick ‘Diagrams’
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Slab Analysis & Design
For beam/slab models, slab reinforcement can be obtained by inserting slab strips in the X and Y
directions. This process uses the moment coefficient method from the tables in BS8110. This is
independent of the general building analysis and can be carried out before or after the building
analysis.
To use the moment coefficient method, it is essential to set all the Slab Types correctly per the tables
in BS8110. This can be done automatically in batch mode by right-clicking on the slab icon in the
structure tree and choosing Set Slab Types Automatically.
➢ From the Structure Tree, double click on storey St: 1 to return to the 1st Storey plan view.
➢ Right-click on Slab → Set Slab Types Automatically → Choose defaults options → OK

Slabs that do not have 4 edges is beyond the scope of the moment coefficient method. It will be
entirely up the user to set the appropriate slab type or use alternative finite element method to
analyse & design these slabs.
➢ Click OK to close the Messages dialog.
➢ Go to the Modelling tab & click on the Slab Strip
The Slab Strip Properties will be displayed:
•

Slab Strip Type: Analytical Strip is used for design based on the Code Method. FE Strip is used for
innovation based on Finite Element Analysis results. Manual strip is used to manually input rebars
without any analysis & design.

•

The correct “At Start” and “At End” boundary conditions must be
specified when drawing the strips. The three options are:
Slab - The Strip starts or ends inside a slab. The bottom
steel for the slab in question is not designed, but the span of the
slab can be defined, and this value is used in determining the
support steel extension.
Bob - The Strip starts or ends beyond an edge beam or wall.
The support steel at the edge is bent down into the beam/wall.
Cantilever - The Strip starts or ends beyond a cantilever
slab.
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➢ Set the Dir: to X
➢ Set the No: to ‘1’ so that the strip label is X1
➢ Set Type to Analytical Strip
➢ Set the At Start condition to Bob.
➢ Set also the At End condition to Bob.
Pick the slab strip’s start point outside the floor plan, as shown below.
➢ Hold down on the CTRL key and then click the end of the strip to the
right of Axis 4

➢ Draw another similar slab strip X2 to obtain the design for the slabs between Axis B-C/1-2
➢ Draw similar slab strip X3 to obtain the design for the slabs between Axis B-C/3-4
➢ Draw slab strip X4 to obtain the design for the slabs between Axis C-D/1-4
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Now draw the vertical strips to design Y-direction rebar for the slabs.
➢ Change the Dir to Y
➢ Reset the No: to 1 again so that the strip label is Y1
➢ Keep Type as Analytical Strip
➢ Keep the At Start condition as Bob
➢ Also, keep the At End condition as Bob
➢ Draw 4 nos. of the vertical strip through all of the slabs
The final layout of strips & slab reinforcements should be as shown
below.

We can now re-check the strips as a batch and create a slab analysis & design report.
➢ Go to the Design tab → choose Slab Analysis and Design
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The slab analysis & design dialog will appear with a summary of pass / fail status, utilization ratio &
reinforcement. The functions at the top menu bar are :
❖ Interactive Design: Select a slab strip > Interactive Design will allow access to detail strip design
❖ Slab Strip Design (Batch Mode): Redesign or re-check the existing design of all strips at once
❖ Check Slab Thickness: If applicable to the selected code, check the sufficiency of slab thickness.
❖ Settings & Parameter: Opens up the slab design settings in the Settings Center
❖ Filter: Allows filter by a storey, slab thickness, and design status
❖ Copy Bars & Paste Bars: Allow copy & paste of bars of similar slabs marked with = symbol
❖ Design Report: Prints out the design report

➢ Click Design Report
The Slab Reinforcement Design report will be displayed. Options are available to configure and then
print it. Any failure in the design will be highlighted in the Notifications pane at the left.

➢ Review the report and then Exit
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Design Status
The design status can be displayed graphically in the plan or 3D window.
➢ Click on the 3D view to make it active
➢ Go to Review Tab → pick Design Status → OK
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Quantity Extraction Tables
The concrete and Formwork quantity reports can be produced.
➢ Go to the Drawings & Reports tab → Pick Quantity Extraction Tables
➢ Choose Concrete Quantity Extractions Table → click Calculate
As shown below, this produces a concrete quantity report with member type and storey breakdown.

➢ Click Report to produce a detailed report

Project Preferences
The Project Preferences dialog allows you to enter the details of the project model.
➢ Go to Building Setout tab → Click on Settings Center → Project Preferences → Header

Title - Enter the Consultant and Project details to be displayed in the header of all the reports.
Statistics - Show graphical chart of essential model information such as the total number of members,
members types, grids & storeys. In addition, it shows the number and types of foundation, beam &
column end releases. A text file can be created.
Notes - Enter additional information on this model, such as revision changes, etc.
➢ Key in the various information in the Title tab as desired
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Report Manager
The Report Manager is the central report manager where all analysis and design reports can be
accessed and managed.
➢ Go to the Drawings & Reports tab → choose Report Manager

Reports Repository

Report Sets

Notifications

•

Report Sets (left): This shows the constituent reports, which will be complied & combined into a
single final report.

•

Reports Repository (middle): All the individual reports generated and available to be included as a
Report Set.

•

Notifications (right): Important notes and warnings from the model’s analysis are shown for easy
reference.

You can expand or collapse the main folder by clicking on topic icons. To create a combined report :
➢ Select New

in the Report Sets tab and give the new report set a name

➢ Select Add All Available
reports in the Reports window to include only available and generated
reports in the report repository.
Alternatively, click and drag a report from the Reports Repository into the report Sets pane.
➢ Choose to insert Table of Contents
tab.
➢ Select View

and Summary Report

using icons below the report Sets

to generate and view the report set.

Other useful functions include loading of company logo : Load Logo
inserting external .doc or .rtf files : New Report from File

.

, inserting QR Code

&
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Steel Model
We will now start a new steel model. This section will cover steel members, trusses modeling, analysis
& design. The below is the screenshot of the completed model, which can also be found in the default
Project Data folder.

➢ Click New Project

and type the project name as shown using the ‘_’ character for spaces.

➢ Select Singapore (Eurocode) template and then OK
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Axis Creating & Storey Insertion
➢ Go to Modelling tab → Pick Orthogonal Axis Generator in the Modelling tab
➢ Pick the intersection of the primary grid near the origin (5000,5000 coordinate)
➢ In Orthogonal Axis Generator, change Dir-2 Axis Spacing to 5000*2 & click OK

➢ Right-click on Storeys in the Structure Tree and pick Add new Storey

➢ Input Total No. of Storeys = 2 → OK
➢ When prompted to confirm → Pick Yes → The plan view will now change focus to Storey 2
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Materials & Load Case / Combination Generator
➢ Go to Analysis tab → Building Analysis → Pre-Analysis tab
➢ Pick Edit Materials → Change the steel grade of all members to S355 (as shown below)

The global materials grade of the truss, purlins, girts & brace members are shown & can be changed.
Individual
member
materialmust
canbealso
be changed
theirloads
respective
Section
Load
cases and
combinations
generated
first toininsert
for purlins
& girtsManager
later. dialog by
selecting the member → Right-click → Edit Section / Material.
We will now auto-generate the load cases and combination (required to add roof purlins loads).
➢ Pick Loading Combination to access the Load Combination Editor

➢ Pick Loading Generator → Pick the options as shown below → click OK

➢ Load cases & combinations will be generated. Pick OK & Close the building analysis menu.
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Steel Columns Creation
➢ Click on Steel Column
in the Modelling
tab.

➢ In Column Properties, change Len (Storey) to 2
This means the column will span 2 storeys with effective length of
2 storey height. Thus, we do not need to model any column in
ST01.
➢ Change the Angle of rotation to 90 degrees
This will rotate the steel section 90 degrees on plan view.
➢ Pick Section Manager icon
This will launch the Section Manager dialog which allows us to
pick a section profile.
Column End Condition : Columns ends are fixed by default. You
can apply hinges to top and/or bottom by clicking successively on this
icon.

➢ In Section Manager dialog, pick Singapore
This will access to Singapore Steel Profiles
(Continental)
➢ Pick UB 250x250x67 → Select
➢ Pick OK to close the dialog
➢ Enter eight nos of columns along Axis 1/A-D & 3/A-D
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➢ Right-click on Views in the Structure Tree and pick 3D Physical Model.

This command will create a separate window showing the 3D view.
➢ Go to Views tab → Tile Vertical
This command will arrange the 3D view and plan view in 2 windows.
➢ Click on the Plan view to make it active (the active view title & border will be darker)
➢ Double-click on Storey 1 in the Structure Tree to switch focus to Storey 1

➢ Click on the Steel Column icon
➢ Change Len (Storey) to 1 in Column Properties
This property means that the column will only span a single storey.
The columns with “Len = 2” are grey in ST01 because they were inserted in ST02.
➢ Ensure the angle of rotation is 90 degrees
➢ Pick Section Manager icon
➢ Ensure that the same UB 250x250x67 is selected.
➢ Insert three nos. of the column along GL2/B to D.
Check the 3D view to ensure the columns were properly
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Steel Beams Creation
➢ Click on the 3D view to make it active (the active view title & border will be darker)
➢ Double-click on Storey 1 in the Structure Tree to switch focus to Storey 1.
Notice the grids will move to storey 1. This operation ensures beams to be created in St: 1 in the
3D view.
➢ Click on Steel Beam icon
➢ Click on Section Manager

in Beam Properties
➢ In Section Manager dialog, pick Singapore flag
This will access to Singapore Steel Profiles
(Continental)
➢ Pick UB 250x125x25 → Select
➢ Pick OK to close the dialog

➢ End Releases: Click successively to hinge both ends of the beam
➢ Click on the 3D view to make it active > Double-click on St: 1 to make it the active storey.
➢ In the 3D view, create seven nos. of beams in the region bounded by GL B, D,2 & 3 (as shown
below)
1

1
1

1

1

1

1
1

1
1

1

➢ Go to the plan view of ST01 → Create four nos. of UB 200x150x30 secondary beams in the region
bounded by GL B, D,2 & 3 (as shown below)
➢ Ensure both ends of the beams are hinged
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Use smart points @ 0.33 &
0.67 to create these beams

Use smart points to create secondary beam. With beam properties out, place the mouse cursor at the
edge of the primary beam (not center) & the smart points will appear at 0.25L, 0.33L, 0.5L & 0.75L.
Use Beams Sections
in the Review tab to show beams of different sizes by color. Assign colors to
members in Section Manager dialog → Material Color

Steel Truss Creation
We will now insert roof trusses. Trusses are best inserted using the 3D view.
➢ Go to the 3D view → Double-click on St: 2 in Structure Tree to make it active & grids are at St: 2
➢ Click on the Truss icon
➢ Pick grid intersections A/1 to define the start
of the truss.
A dynamic rubberband will appear with the
default truss type if no truss is defined before.
➢ Pick grid intersections A/3 to define the end of
the truss.
After you pick the second point, the truss
generator dialog will appear.
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➢ In Geometry, pick Duo-Pitched truss → Change Truss Support Placement to Top chord
➢ Change Apex height to 1500 mm, Left & Right Heel height to 800 mm
➢ Click on the Members tab

00

➢ Change the truss member sections to the following by click on the section name :
•
•

Top & bottom chord = RHS 150x75x3 (Singapore)
Diagonals & Verticals = SHS 75x75x3 (Singapore)

➢ Click OK to exit the Truss Generator dialog.
The truss will be inserted. The truss insertion will automatically switch into copy mode & you can pick
the next point of insertion.
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x
x
x

➢ Insert 3 nos. of similar trusses by clicking grid
intersection B/1, C/1 & D/1
➢

Press ESC or Right-Click to end the copy
operation

To enter copy mode manually, select the truss →
Right-click → Pick Copy
➢ Select the basepoint @ intersection of A/1
➢ Insert 3 nos. of similar trusses by clicking grid
intersection B/1, C/1 & D/1

Purlins Creation
We will now insert purlins on the roof trusses. Purlins are best inserted using the 3D view.
➢ Click on Purlin toolbar button
➢ Select the first truss @ GL A → Select the last truss @ GL D (Intermediate trusses will be
automatically found)
➢ On Purlin Dialog, you can specify the following:
•

Profile / Section of the for the Purlin

•

Section Alignment: On the Section / Under the Section / Center

•

Generation Method: By Truss Joints / By Spacing

•

There are many other options. Refer to the diagrams as a guide.

•

The 3D diagram on the right can be rotated (right-click & drag) & zoom in/out (mouse wheel)
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➢ Choose section UPN100 (under Steel → European sections → UPN)

➢ In the Sag Rods dialog → Insertion Method → Choose None to remove all sag rods (for simplicity)

➢ Pick OK to exit the purlins dialog.
We will insert the roof loading using the more specific Cladding function.

Creating Cladding & Loads
➢ Go to Modelling tab → Pick Cladding

→ Select any purlin

The Cladding dialog will appear to insert roof loads on the purlins.
In the Geometry dialog, the cladding geometry can be adjusted by selecting the point and changing
the values in the vertical and horizontal direction.
Point

Horizontal Dir Vertical Dir

P1

➢ Click OK to exit the cladding dialog > The cladding will be rendered on top of the purlins.
➢ Go to the Structure Tree > Cladding > Select the cladding label
➢ Right-click > Pick Edit Loads
The load editor dialog will appear, which allows you to insert area load on the cladding.

Page - 84

➢ At the top, pick Full Uniform Area Load
➢ Pick G Load Case in the left pane
➢ In Load Properties, ensure Load Direction = Gravity & Magnitude = 0.5 kN/m2
➢ Click “Apply All” to apply to all panels.
Alternatively, you can click on each panel or click & drag window to apply on multiple panels
➢ Pick Qr Load Case (Roof Live) in the left pane & Full Uniform Area Load
➢ In Load Properties, ensure Load Direction = Gravity & Magnitude = 0.7 kN/m2
➢ Click “Apply All” to apply to all panels
➢ Click OK to save & exit the load dialog
➢ You can switch off the cladding Layer
by going to the Display tab.
This operation will make the view less cluttered & make the selection of other members easier.

Braces Creation
We will now insert some bracings between steel columns.
➢ Click on the Brace toolbar icon
➢ Pick two adjacent columns at A/1 & B/1 → Brace Dialog will appear
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➢ In the Brace dialog, you can specify the following:
• Profile / Section of the for the braces
• Brace Type (Diagonal, X Brace, Y Brace or K Brace)
• Alignment & Top/Bot Offsets
• Apply to analysis: offsets will affect the analytical model
➢ Accept all defaults & click OK
➢ Insert the same bracing between columns A/3 & B/3
➢ Check the braces are correctly inserted, as shown below

➢ Insert new brace between columns C/3 & D/3
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➢ Change Brace Type to Diagonal
➢ Input J End y-Offset = 3000 mm (rest remains 0 mm)
➢ Tick Apply To Analysis: J End Offsets
This option will ensure the analysis frame will accurately consider this offset.
➢ Click OK → Diagonal Brace will be inserted
➢ Insert another new diagonal brace between the same columns C/3 & D/3

➢ Ensure Brace Type = Diagonal
➢ Tick Invert → this will invert the diagonal
➢ The input I End y-Offset = 3000 mm (rest remains 0 mm)
➢ Tick Apply To Analysis: I & J End Offsets
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This option will ensure the analysis frame will accurately consider this offset.
➢ Click OK → A new diagonal brace will be inserted
➢ Check the braces are correctly created in the 3D view as below.
Horizontal braces can also be inserted between beams. Create three horizontal braces connecting the
beams in ST01, as shown below.
➢ Pick 2 adjacent beams
➢ In the Brace dialog, pick Brace Type =
Diagonal
➢ Tick / Untick Invert as required by verifying
the right-side brace diagram.
➢ Ensure all I & J End Offsets = 0
➢ Click OK

Model 3 horizontal
braces

➢ Check the brace is correctly created as
shown in the left figure.
➢ Repeat the same steps to create total of 3
horizontal braces as shown in the figure.
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Girts Creation
We will now insert some girts between steel columns.
➢

Click on Girt toolbar button

➢

Select the first column at grid A/3 → Select the last column at grid D/3.

Intermediate columns will be automatically found.
➢

In the Geometry dialog, you can specify the following:

•
•
•

Profile / Section of the Girt
Section Alignment: Under The Section / On The Section
Spacing, Delete Bottom / Top Member, Left / Right Cantilever, Offsets

➢

Ensure Profile is UPN100 (under Steel → European sections → UPN)

➢

Ensure Section Alignment is On The Section

➢

Tick “Delete Bottom Member” so that bottommost Girt is removed.

In the Sag Rods dialog, you can specify the configuration of the sag rods. For simplicity, we will not
insert the sag rods for this model, as there are minor elements.
➢

In the Sag Rods dialog → Insertion Method → Choose None to remove all sag rods

➢

Click OK, and the girts will be inserted.

➢

Insert similar girts between columns A/1 & C/1 but Section Alignment = Under the Section

➢

Check the girts are inserted correctly at both sides of the building, as shown below
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Loads can be applied to girds similar to Purlin by creating a cladding first. For simplicity, we skip this.

Column Splice Creation
➢
➢
➢
➢
➢

Press ESC to deselect all members
Select the corner column at GL D/3
Right-click → Define Splice
Pick Add New Splice in Splice Location Definitions
In Member Splice Definition choose :

• Reference Strorey = 1
• Splice Distance (from floor level) = 800 mm
• Splice width = 500mm
➢ Click OK
The splice will be created & listed in Splice Location
Definitions.
➢ Close Splice dialog

Building Analysis
➢ Go to the Analysis tab → Pick Building Analysis
➢ In Batch Design Options, choose not the design any members → click Building Analysis
Once analysis is completed, the Analytical Model view will open automatically.
➢ Review the results in the Analytical Model view to your satisfaction as outlined in previous section.
For example, check if the roof cladding loads have been correctly considered by switching on the
Frame Loads & Frame Load Labels.
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Steel Design
Steel member design commands can be accessed via the Design tab

➢ Go to Design tab → Design All → Pick Steel Member Design Check → OK
❖ This will check all the adequacy of assigned all steel members in one go.
❖ The program does not automatically select the smallest section size.
❖ If the model is large, it is recommended to perform design check by member types separately.
❖ To access a summary of member design check, select the steel member icons in the steel
group.
❖ To design only a single member, select it → Right-click → Steel Member Design
➢ Pick steel Column Design
❖

to access the design summary of all steel columns.

➢ Double-click on any column to review the detailed design checks.
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➢ Click on the triangle

next to the title check to drill down to more details

➢ Check Design → Re-check the design of this column
➢ Change Section → Allow you to pick another section → New section will be checked automatically
for pass/fail.
➢ Design Report → Prepare the design report
➢ Show Design Stations → List out all the design forces of all load combinations
➢ Show Diagrams → Show design force diagrams for load cases, load combinations & envelope
➢ Parameters Tab > Buckling → Input Braced length, Buckling Length Coefficient, Lateral Torsional
Buckling length
➢ Parameters Tab > Deflection→ Manually edit deflection limits
Effective lengths are automatically detected &calculated by the program based on restraints provided
by connected members. You can change them if you wish.
➢ Go to the Parameter tab
➢ Tick Manually edit buckling parameters
➢ Input various Braced Length
❖ ‘0’ (Zero) means auto-calculate values. Hence,
only input values to over-write them.
❖ It is highly recommended you review the autocalculated values and amend to suit your design
assumptions.
➢ Go back to Design Summary to check the design
❖ Deflection limits can be modified using similar
steps.
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➢ Pick OK to close the column design dialog
➢ Pick Trusses

to design the trusses

➢ Double-click on the truss 2T2 to access the detailed steel truss design

Selected member colored purple

➢ Reset View → Reset the truss diagram to the original orientation.
➢ Show Label → Reset the truss diagram to the original orientation.
➢ Show Utilization Ratios → Show Utilization ratio for each member.
❖ Pass / Failed members are shown clearly in Green / Red
❖ Slenderness Ratio failure will not result in FAIL status as it is not a critical criterion (more a
warning)
❖ Fail members (UR > 1) will be colored red in the truss diagram.
❖ The selected member in the table will be colored purple in the truss diagram.
❖ The truss diagram at the bottom can be zoomed (mouse wheel) & rotated (right-click & drag).
➢ Double-click on the failed bottom chord member → This will bring up detailed member design
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This bottom member fails in Axial Compression Check & Combined Forces Check. You can increase the
section size or thickness to solve the failure. However, before doing that, let us review effective design
lengths. In the results, General Parameter, notice that for bottom chord, Lx = 1668 mm & Ly =
10,000mm.
•
•

Lx is the Major Braced Length is auto determined = truss panel length
Ly is the Minor Braced Length is the entire length of the bottom chord between supports
Lx

Ly

Lx
Ly
To reduce the minor bracing lengths bottom chord, you can add bracing members at intermediate
locations joining bottoms chords of the adjacent truss.
Alternatively, go to the parameter > Buckling tab to manually edit the bracing lengths.
➢ If there is a bracing member at the mid-span of the bottom chord, you can change the braced
length Minor, Ly & Lateral Torsional Buckling Length, Lb to 5000mm
➢ Click on Design Summary, and the member will automatically be re-checked & result in a pass
The assumption of top chord is :
•
•

Lx is the Major Braced Length is auto determined = truss panel length
Ly is the Minor Braced Length is auto determined = purlin spacing

You may want to check the steel beam design. The design interface is similar to the column design.
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Design Status & Design Utilization
We can view Steel Design Status and Steel Design Utilization to review pass/failure status & design
efficiency quickly.
The design status can be displayed graphically in the plan or 3D window
➢ Click on the 3D view to make it active
➢ Go to the Review Tab and pick Design Status

➢ Click Visual Interrogation

→ OK

& choose Steel Design Utilization Ratios → OK
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Closing Summary
Congratulations! You have created your first model in ProtaStructure.
We have created, analyzed, and designed a simple small model in this basic training guide. The
guidance provided here will give you the necessary knowledge to proceed to an actual project.
For more help and guidance, please refer to Prota Help Center: https://support.protasoftware.com
We recommend you read the What’s New document for details of new features & enhancements.
The detail drawings of all the members and the general arrangement drawings can be automatically
produced and managed in ProtaDetails (concrete) & ProtaSteel (steel). We recommend you proceed
to read the ProtaDetails & ProtaSteel Quick Start Guide as the next step.
Should you have any technical support requests or questions, please do not hesitate to contact us at
all times through globalsupport@protasoftware.com or asiasupport@protasoftware.com (Asia
Pacific).
Our dedicated online support center is available to help you get the most out of Prota’s technology
solutions with our responsive technical support team.

